Author Topic: First Website!  (Read 2520 times)

0 Members and 1 Guest are viewing this topic.

Offline Jason Prupas

  • Inactive Member
  • Posts: 9
      • Email
First Website!
« on: December 18, 2010, 09:46 PM »
Hey everybody, im a second year photojournalism student at loyalist college, and i just recently completed my first web site. Its quite simple and not much to it but i wanted it that way. Let me know what you guys think, and dont go easy  :)

http://jasonprupas.com/

thanks everybody,

JP



Frederic Sune

  • Guest
  • Posts:
Re: First Website!
« Reply #1 on: December 19, 2010, 04:08 PM »
Hi Jason,

Few remarks to improve the experience on your website:
- First of all, your title is very big and to see your picture on my laptop, I have to scroll down.
- Them, on your slideshow, since you are a photojournalism, it would be nice to have caption on each picture, for example, the dog behind the window, what is the story?
- and, it would be more professional if you have an email address on your domain.
- Finally, on your blog, you show beautiful images but no caption!

Hope it's help,
Frederic



Offline Jason Prupas

  • Inactive Member
  • Posts: 9
      • Email
Re: First Website!
« Reply #2 on: December 20, 2010, 10:40 PM »
Thank you frederic for the feedback, it all will be changed as soon as possible.



Offline Kenneth Armstrong

  • Professional
  • Sault Ste Marie, ON
  • Posts: 308
      • www.kennetharmstrong.ca
      • Email
Re: First Website!
« Reply #3 on: December 21, 2010, 12:10 PM »
Couldn't load your gallery on my iPhone because its in Flash. 99/100 people probably won't access your site with an iPad or iPhone but that 1 client who does will possibly not come back.

Otherwise a lot of it looks good. I need to revamp my site and yours has given me some ideas.


--------------------

ken@kennetharmstrong.ca
www.kennetharmstrong.ca
Photographer
Sault Ste Marie

Offline Jason Prupas

  • Inactive Member
  • Posts: 9
      • Email
Re: First Website!
« Reply #4 on: January 03, 2011, 09:40 PM »
Thank you for the feed back kenneth, ive heard this from a few people and i think the problem is with the Adobe flash slideshow settings i used. I just need to figure out how to change it thats all.



Offline Chris Roussakis

  • Inactive Member
  • Ottawa
  • Posts: 78
      • Email
Re: First Website!
« Reply #5 on: January 04, 2011, 11:08 AM »
Photos are starting to work but it seems as if every second photo doen't work. Also, it could be a good idea to put sections like (sports, portait, news ect ect). I know you have a lot of sports stuff so it might be good to show it off.



Chris Roussakis
-------------------
Freelance Photojournalist
Ottawa, Ontario
613-324-5504
chrisroussakis.com
@chrisroussakis

Adam Jackson

  • Guest
  • Posts:
Re: First Website!
« Reply #6 on: January 05, 2011, 11:15 AM »
You have to change the landing page picture...you have some good stuff in the slideshow that is much stronger, use one of those